Jump to content
Oovee® Games
zidon155

Mods by Zidon ;)

Recommended Posts

Why would you fit a skidder attachment? The mechanism on the back is a Russian style skidder. The logs are winched up to the vertical plate, then it's tilted back. Lots of footage of this type of skidder available on YouTube.

Share this post


Link to post
Share on other sites

Actually afaik that  plate doesn't tilt. it's just a big piece of 1/" steel that you winch the logs clovery close to, and the plate stops the logs from smashing into the frame of the skidder. Ofc, you can just wrap a chain around one end of a log and drag it that way :)

 

55U9uTE.jpg

Share this post


Link to post
Share on other sites

Hohoo! I got it! ;)
LKT has now 3 addons:
1. cistern trailer ( 1000l)
2. mini-log trailer ( 1garage point+200 repairs )
3. skidder addon ( on lumber you can connect logs long/short = 4/2 log points )
:)

 

rjebft.jpg

2namr8m.jpg

b97nup.jpg

i39dgy.jpg

  • Like 3

Share this post


Link to post
Share on other sites

I am still working on an engine/gearbox combo for the LKT. What size are the wheels? (radius from the wheel 'class' xml)

Share this post


Link to post
Share on other sites

Hehe -okey :D

You can post here some your nice screens if you have ;)

 

BTW: all addons work good?  .... maybe add +1 garage point to trailer? ( 2gp total) ? And sometimes your logs from Mule fall thru terrain and whole tractor explodes - has happened to you too?

Share this post


Link to post
Share on other sites

I just added the default cart trailers, no need to reinvent the wheel. The skid logs are sometimes a bit glitchy, not much I can do about that :/

Share this post


Link to post
Share on other sites

I need to do some work on the 1+ calculation, as it's a bit useless right now.

 

Just be aware that I have gone for a realistic tune. And just like the real thing, it's slow, rides really rough, and is no good for long distance work

  • Like 2

Share this post


Link to post
Share on other sites

Some work on front plow made by Tatoo :)

It moves, it works but lot of bug still on it ;)

 

29kwhdw.jpg

2zr001l.jpg

2b5t2f.jpg

Share this post


Link to post
Share on other sites

You can hardly tell by the pics but the cylinders in the middle, where the rear end rotates, work now. And the plow is only buggy because of how the front axle is setup with a <Box HalfExtents= which is set way too big. It's 1m by 1m and is interfering with the plow and when I make it smaller, the whole damn thing wiggs out as well as if I remove it.

 

I also fixed the wheel radius. It was set to .6 but they are actually .749. So I fixed that and centered them on the axles better as well.

Edited by Tattoo
  • Like 1

Share this post


Link to post
Share on other sites

Set the front axle to non-colliding :)

 

Thanks PL. It has ImpactType="Truck" right now and is setup funky because it doesn't have an <axles> section. I can add this and try it, Collisions="Internal", if that's what ya mean.

 

Here's the .xml to show what I'm referring to. The front axle uses a <shape> AND there is a cdt attached to it as well. I've never seen this before so I'm a bit confuse on what to do with it. I was thinking of trying what you did with your articulated frame. I'm gonna see what I can do with that too because I really don't wanna change the way the front axle works but I may have no choice. :(

 

 

 

<?xml version="1.0"?>
<_templates Include="trucks">
	<Wheel>
		<SteerWheel
			DefaultWheelType="_lkt81steer_wheel"
			SteeringAngle="40"
			ConnectedToHandbrake="false"
		>
			<Suspension
				MinLimit="-0.52"
				MaxLimit="0.2"
				Strength="0.009"
				Damping="0.1"
			/>
			<Steering JointOffset="0" Castor="1" />
			<Softness ForceScale="0.3" MaxAccel="0.01" />
		</SteerWheel>
		<FixWheel
			DefaultWheelType="_lkt81fix_wheel"
			ConnectedToHandbrake="false"
		>
			<Suspension
				MinLimit="-0.52"
				MaxLimit="0.2"
				Strength="0.009"
				Damping="0.1"
			/>
			<Softness ForceScale="0.3" MaxAccel="0.01" />
		</FixWheel>
		<FrontWheel
			DefaultWheelType="_lkt81_wheel"
			Torque="default"
			ConnectedToHandbrake="true"
		>
			<Suspension
				MinLimit="0"
				MaxLimit="0.02"
				Strength="0.008"
				Damping="0.1"
			/>
		</FrontWheel>
		<RearWheel
			DefaultWheelType="_lkt81_wheel"
			Torque="default"
			ConnectedToHandbrake="true"
		>
			<Suspension
				MinLimit="-0.2"
				MaxLimit="0.2"
				Strength="0.07"
				Damping="0.14"
			/>
			<Softness ForceScale="0.3" MaxAccel="0.01" />
		</RearWheel>
	</Wheel>
</_templates>
<Truck>
	<GameData FuelCapacity="300">
		<Socket Type="hook" ParentFrame="BoneChassisRear" Offset="(-2.0; 0.7; 0)" />

		<AddonSockets>
			<MiniLogTrailer ParentFrame="BoneChassisRear" Offset="(-1.7; 0.54; 0.0)" />
		</AddonSockets>
		<AddonSockets>
		         <T40CartTrailer ParentFrame="BoneChassisRear" Offset="(-1.7; 0.54; 0.0)" />
		</AddonSockets>
		<AddonSockets>
			<bulldozer_skid ParentFrame="BoneChassisRear" Offset="(-1.57; 0.978; 0.0)" />
		</AddonSockets>
		<AddonSockets>
			<LoadLogsSkid ParentFrame="BoneChassisRear" Offset="(-1.86; 1.03; 0.0)" />
		</AddonSockets>

		<WinchSocket ParentFrame="BoneChassisRear" Offset="(-2; 2; 0.25)" />

		<WinchSocket ParentFrame="BoneChassisRear" Offset="(-2; 2; -0.25)" />
	</GameData>
	<TruckData
		SteerSpeed="0.013"
		SteerResponsiveness="0.1"
		BackSteerSpeed="0.02"
		EngineStartTime="3.2"
	>
		<Damage
			Capacity="1000"
			SensationOrigin="(2.25; 2.34; 0)"
			SensationSize="(0.95; 0.64; 1.54)"
			ParentFrame="BoneChassisFront"
		/>
		<Sound
			_template="Ural"
			Offset="(1.50525; 1.96228; 0.0)"
			Range="12.0"
		>
			<AbruptStop Sound="truck/swing" />
			<ChassisStress Sound="truck/stress" />
			<BrakePull Sound="truck/brake_pull" />
			<BrakeRelease Sound="truck/brake_release" />
			<Handbrake Sound="lkt81/handbrake" />
			<Gear Sound="truck/gear" />
			<DiffLock Sound="truck/difflock" />
			<Crackle Sound="truck/crackle" />
			<ExhaustShot Sound="truck/shot" />
			<Headlight Sound="truck/headlight" />
			<EngineIdle Sound="lkt81/EngineIdle" />
			<EngineLow Sound="lkt81/EngineLow" />
			<EngineHigh Sound="lkt81/EngineHigh" />
			<EngineHeavy Sound="lkt81/engine_heavy" />
			<EngineTurbo Sound="lkt81/engine_turbo"/>
			<EngineStart Sound="lkt81/start82" />
			<EngineRev Sound="lkt81/reverse82" />
			<EngineStartDelay Value="3.5" />
			<ExhaustStartTime Value="2.4" />
			<ExhaustFadeStartTime Value="3.6" />
			<ExhaustStopTime Value="7.6" />


		</Sound>
		<Exhaust Origin="(1.45; 2.85; -0.4)" Velocity="(-4; 3; 0)" />
		<Camera Cabin="(0.9; 2.5; 0.0)" IsHood="true" RadiusMultiplier="0.8"  />
		<Steam Origin="(1.5; 0.9; 0)" />
		<Steam
			Origin="(4.0; 1.5; 0)"
			ParentFrame="BoneChassisFront"
			Scale="0.5"
		/>
		<OcclusionMap
			Texture="occlusion/chassis__d_a_uncmp.tga"
			Size="(0.0; 0.0)"
			Offset="1.1"
		/>
		<OcclusionVolume
			Size="(0.0; 0.0)"
			HeightFront="1.3"
			HeightRear="0.75"
			Offset="0.9"
		>
			<FullOcclusion HeightFront="1.1" HeightRear="1.3" />
		</OcclusionVolume>
		<Shakers>
			<Shaker
				Frame="exhaustbone"
				MaxAngle="(2; 2; 2)"
				MaxFrequency="10"
			/>
		</Shakers>
	</TruckData>
	<HeadLight
		_template="Default"
		ParentFrame="front"
		Offset="(3; 1.5; 0.0)"
	/>
	<PhysicsModel Mesh="lkt81/lkt81_chassis.xml">
		<Body
			ModelFrame="BoneChassisFront"
			Mass="5000"
			CenterOfMassOffset="(-0.5; -0.8; 0)"
		>
			<Body
				ModelFrame="axlefront"
				Mass="1000"
				CenterOfMassOffset="(0; -1; 0)"
				ImpactType="Truck"
			>
				<Shape>
          				<Box HalfExtents="(1; 0.1; 1)" Translation="(0; 0.2; 0)" />
				</Shape>
				<Constraint
					Type="Hinge"
					MinLimit="-10"
					MaxLimit="10"
					Axis="(1; 0; 0)"
				>
					<Motor
						Type="Spring"
						Spring="20000"
						Damping="10000"

					/>
				</Constraint>
			</Body>
			<Body
				ModelFrame="BoneChassisRear"
				Mass="4000"
				CenterOfMassOffset="(0.5; -0.8; 0)"
				ImpactType="Truck"
			>
				<Constraint
					Type="Hinge"
					MinLimit="-40"
					MaxLimit="40"
					Axis="(0; 1; 0)"
				>
					<Motor
						Type="Spring"
						Spring="2000"
						Damping="1000"
					/>
				</Constraint>
			</Body>
			<Body
				ModelFrame="BonePlow_cdt"
				Mass="100"
				Collisions="Internal"
				>
				<Constraint
					Name="Plow"
					Type="Hinge"
					Axis="(0;0;-1)"
					MinLimit="-5"
					MaxLimit="45"
					>
					<Motor
						Type="Position"
						Force="20000"
						/>
				</Constraint>
			</Body>
		</Body>
	</PhysicsModel>
	<ModelAttachments>
		<Ignition>
		</Ignition>
		<HeadLight>
			<Flare
				_template="HeadLight"
				ParentFrame="front"
				Offset="(2.7; 1.7; -0.37)"
			/>
			<Model
				_template="HeadLightRay"
				ParentFrame="front"
				Org="(2.78; 1.7; -0.37)"
			/>
			<Flare
				_template="HeadLight"
				ParentFrame="front"
				Offset="(2.7; 1.7; 0.37)"
			/>
		</HeadLight>
	</ModelAttachments>
	<ControlledConstrains>
		<RotatePlow Name="Plow" />
	</ControlledConstrains>
	<AutomaticIK>
		<IKBone ModelFrame="BoneTubeR" ParentFrame="BoneChassisFront">
			<IKJoint Type="Hinge" Axis="(1;0;0)" />
			<IKBone
				ModelFrame="BonePistonR"
				AttachToFrame="BoneChassisRear"
				AttachOffset="(0; 0; 0)"
			>
				<IKJoint Type="Slider" Axis="(0;1;0)" />
			</IKBone>
		</IKBone>
		<IKBone ModelFrame="BoneTubeL" ParentFrame="BoneChassisFront">
			<IKJoint Type="Hinge" Axis="(1;0;0)" />
			<IKBone
				ModelFrame="BonePistonL"
				AttachToFrame="BoneChassisRear"
				AttachOffset="(0; 0; 0)"
			>
				<IKJoint Type="Slider" Axis="(0;1;0)" />
			</IKBone>
		</IKBone>
<!--		<IKBone ModelFrame="BonePlowTubes" ParentFrame="BoneChassisFront">
			<IKJoint Type="Hinge" Axis="(0;0;-1)" />
			<IKBone
				ModelFrame="BonePlowPiston"
				AttachToFrame="BonePlow_cdt"
				AttachOffset="(0; 0; 0)"
			>
				<IKJoint Type="Slider" Axis="(0;1;0)" />
			</IKBone>
		</IKBone>
-->	</AutomaticIK>
	<VehicleConstraint>
		<ReverseGear
			Torque="85000"
			AngVelMin="-2.0"
			AngVelOpt="0.2"
			AngVelMax="6.0"
			LinVelMax="1.8"
			MaxDeltaAngVel="0.05"
		/>
		<HighGear
			Torque="100000"
			AngVelMin="0.3"
			AngVelOpt="5.0"
			AngVelMax="8.0"
			AutoNextLinVel="3.8"
			MaxDeltaAngVel="0.1"
		/>
		<Gear
			Torque="86000"
			AngVelMin="-2.0"
			AngVelOpt="1.0"
			AngVelMax="5.0"
			AutoNextLinVel="1.5"
			MaxDeltaAngVel="0.05"
		/>
		<Gear
			Torque="81000"
			AngVelMin="-2.0"
			AngVelOpt="1.0"
			AngVelMax="5.0"
			AutoNextLinVel="1.5"
			MaxDeltaAngVel="0.05"
		/>
		<Gear
			Torque="70000"
			AngVelMin="-0.5"
			AngVelOpt="2.0"
			AngVelMax="9.5"
			AutoNextLinVel="3.8"
			MaxDeltaAngVel="0.01"
		/>
		<Gear
			Torque="51000"
			AngVelMin="0.6"
			AngVelOpt="3.5"
			AngVelMax="16.0"
			AutoNextLinVel="6.3"
			MaxDeltaAngVel="0.01"
		/>
	</VehicleConstraint>
	<Wheels>
		<Wheel _template="FixWheel">
			<Suspension Hardpoint="(0.3; 1.4; 0.6)" />
		</Wheel>
		<Wheel _template="FixWheel">
			<Suspension Hardpoint="(0.3; 1.4; -0.6)" />
		</Wheel>
		<Wheel _template="SteerWheel" ParentFrame="BoneChassisRear">
			<Suspension Hardpoint="(0; 1.4; 0)" />
		</Wheel>
		<Wheel _template="FrontWheel" ParentFrame="axlefront">
			<Suspension Hardpoint="(1.382; 0.72; 0.9)" />
		</Wheel>
		<Wheel _template="FrontWheel" ParentFrame="axlefront">
			<Suspension Hardpoint="(1.382; 0.72; -0.9)" />
		</Wheel>
		<Wheel _template="RearWheel" ParentFrame="BoneChassisRear">
			<Suspension Hardpoint="(-1.083; 0.72; 0.9)" />
		</Wheel>
		<Wheel _template="RearWheel" ParentFrame="BoneChassisRear">
			<Suspension Hardpoint="(-1.083; 0.72; -0.9)" />
		</Wheel>
	</Wheels>
</Truck>

 

 

Edited by Tattoo

Share this post


Link to post
Share on other sites

Use collisions="none" to make it completely non-colliding.

 

Also set the minlimit to 0 and strength to 1 on all the wheels :)

Share this post


Link to post
Share on other sites

Use collisions="none" to make it completely non-colliding.

 

Also set the minlimit to 0 and strength to 1 on all the wheels :)

 

Thanks. I'll try that.

 

The minlimit and strength was set to that in the first version he gave me but it was just changed in the second version he gave me. Couldn't tell ya why, tho.

 

I think I need to set it up a bit different tho. I'm gonna give the plow a main bone and attach that to the chassis and see if that helps any. Right now the plow is attached to the chassis bone and wanna see if it helps with a main bone like an attachment is setup. I tried attaching it to the chassis cdt like the crane and it did work but glitched the same when lowered and going thru mud. The pivot is moving and it shouldn't.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...