Jump to content
Oovee® Games

Recommended Posts

Well, this is rather interesting. A while ago I played a game on the Aftermath map. I stopped after going to the north-west river crossing to the garage, getting stuck there in a B-133. (I don't really like that you can only get to that garage by going across the only uncollapsed bridge, but oh well. Maybe that river crossing should be a bit shallower.) Anyway, I reinstalled ST+ recently and just started another Aftermath issue when my truck sunk into the ground at the first garage:20200405135659_1.thumb.jpg.fe31d106caaf427c307418de2e5103a0.jpg

I remember posting this as an issue before and Zane being confused as to why it happened, as it didn't when they were developing the map. Therefore, I find it reasonably likely that this is caused by ST+. @Localhost (Oovee) Do you know anything about this? Perhaps it does something with the terrain type?

Edited by DeltΔV
Link to post
Share on other sites
  • Replies 569
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Spintires Plus v14 has been released. This is a compatibility update with game v1.6.2. Other changes: -OrientableShafts: bugfix: shaft endpoints weren't always correctly aligned, often b

@Truckwolf: As I said, the mud has new bugs, one of them causes light wheels on the 255 to dig in place, not because of ground pressure, but because they vibrate fast, which is as if they were spinnin

Spintires Plus v15 has been released. This is a compatibility update with game v1.7.0, plus a couple extras: -AlwaysAllowSpawnLocators: due to a bug, this is already in the game v1

Posted Images

13 minutes ago, Sandmansa said:

I don't think it's a ST+ related issue, because when I ran it vanilla, I was having the same problem.  The B-133 just sinks in to the mud like it weighs 5 times more than it's suppose to.

well, after removing spintires plus it works absolutely fine for me.

Link to post
Share on other sites
  • 3 weeks later...
7 hours ago, Blake3020 said:

WILL SOMEONE PLEASE HELP I HAVE BEEN TRYING TO GET SPINTIRES+ FOR 3 HOURS NO MATTER WHAT VERSION I DOWNLOAD OR HOW I DO IT IT WILL NOT LET ME LAUNCH THE GAME WITH THIS MOD INSTALLED PLEASE HELP!!!

Maybe, If you don't spam caps lock.

Link to post
Share on other sites
17 hours ago, Blake3020 said:

sorry i was just really frustrated last night but i still never got it so some help would be appreciated 

Ok :) I got it to work by disabling STPControlledConstraints in the config file. And I used the V12 version.

If that's not clear enough,

<Modding
		CustomizableTrailerBreakoffForce="true"
		ExtraAddonProperties="true"
		MapsCanOverrideCloakMesh="true"
		OrientableShafts="true"
		STPControlledConstraints="false" <!-- this is the bit you change -->
		SupportCustomShafts="true"
		SupportSkidSteering="true"
		SupportAdditionalConstraints="true"
		SupportWorkshopMedia="true"
		SuspensionTunableInWheelsSets="true"
		UnclampedXML="true"
		UnclampedManualLoads="true"
		WheelsetsCanRequireAddons="true"
	>
		<ConstraintController IncreaseKey="45"  DecreaseKey="46"  ResetKey="8"/>
		<ConstraintController IncreaseKey="36" DecreaseKey="35" ResetKey="8"/>
		<ConstraintController IncreaseKey="33" DecreaseKey="34" ResetKey="8"/>
	</Modding>

 

Edited by DeltΔV
Link to post
Share on other sites
7 hours ago, DeltΔV said:

Ok :) I got it to work by disabling STPControlledConstraints in the config file. And I used this version.

If that's not clear enough,


<Modding
		CustomizableTrailerBreakoffForce="true"
		ExtraAddonProperties="true"
		MapsCanOverrideCloakMesh="true"
		OrientableShafts="true"
		STPControlledConstraints="false" <!-- this is the bit you change -->
		SupportCustomShafts="true"
		SupportSkidSteering="true"
		SupportAdditionalConstraints="true"
		SupportWorkshopMedia="true"
		SuspensionTunableInWheelsSets="true"
		UnclampedXML="true"
		UnclampedManualLoads="true"
		WheelsetsCanRequireAddons="true"
	>
		<ConstraintController IncreaseKey="45"  DecreaseKey="46"  ResetKey="8"/>
		<ConstraintController IncreaseKey="36" DecreaseKey="35" ResetKey="8"/>
		<ConstraintController IncreaseKey="33" DecreaseKey="34" ResetKey="8"/>
	</Modding>

 

when I click on the link for the version you used it said error so I just got v12 and I extracted the files and put them into my spintires folder and changed what you told me to and still nothing its like it tries to start like a black screen just comes up and then it just crashes so if I'm doing something wrong let me know but I just cant seem to get it   

Link to post
Share on other sites
8 hours ago, Blake3020 said:

when I click on the link for the version you used it said error so I just got v12 and I extracted the files and put them into my spintires folder and changed what you told me to and still nothing its like it tries to start like a black screen just comes up and then it just crashes so if I'm doing something wrong let me know but I just cant seem to get it   

sorry i did mean v12, try this config file: https://drive.google.com/file/d/1hv7A3wQqVb6ssN6cn5OsHhbZ10oQGROe/view?usp=sharing

Link to post
Share on other sites
  • 3 weeks later...

-Go to profiles-> + -> point to spintires.

-Go to shaders, take your pick (I used SplitScreen because it has a very visible effect).

-Save, validate, & close assistant.

-Go to spintires' directory and rename the 480+kb d3d9.dll into Reshade32.dll

-Reinstall ST+, add Reshade32.dll as a plugin.

-Play.

If anything reshade-related goes wrong outside that caveat, then I cannot help you.

 

 

Side note:FOV and aspect ratio change have been coded, they'll be in ST+ v2.

Moving on to per-wheelset suspension tweaks.

Link to post
Share on other sites
Just now, NA-AnEngineer said:

Is the v12 compatible with the 1.4.5 ST? I tried tu run it with everything off in the config and DLC Disabled but its still just a blackscreen for 5-10sec and crush.

You need to turn off "STPControlledConstraints" in the config file, I believe. Use this config file, it should work:SpintiresPlus_config.xml

Link to post
Share on other sites
Quote

You need to turn off "STPControlledConstraints" in the config file, I believe. Use this config file, it should work

I tied it first manuly but it wasn't working anyway. But with your config file its runing perfect. Thanks .👍

 

Edited by NA-AnEngineer
My bad English
Link to post
Share on other sites

Hey squad. Was FINALLY able to get ST+ (v12) back up and running with delta vees xml. So thank you. However, it doesn't seem to be allowing me to use electric winches? Which... was the whole reason I even got ST+ way back in the day lol...

It's marked true, 88 and I set length to about 28 iirc. Nothing. As I said, I'm using deltavs xml a couple posts up if anyone cares to advise?

Thanks

Link to post
Share on other sites

Well squad, I was able to get another xml that allowed the winch to work. I've been comparing delta vees and this one and don't notice anything but I'm fairly sleep deprived currently. Regardless, thanks and it seems I'm up and running again!

Link to post
Share on other sites
  • 1 month later...

Spintires Plus v13 has been released.

This is a compatibility update with game v1.5.1.
Other notes:

  • AlternateTruckMenu has been removed, which means SelectStartupAddons is no longer usable. As I said earlier, sorry, I don't have the strength to rewrite this for the new truck menu.
  • AlternateMapMenu has been removed, since v1.5.0 finally added a scrollbar to the map menu making this feature no longer vital.
  • The above 2 mean that ST+ no longer has custom menus, thus AntTweakBar is no longer needed. That's why there is no AntTweakBar.dll anymore.
  • HavokBufferSize has been removed, if the absence of this option causes crashes then it's an issue with the game and should thus be fixed in the base game. Plus it's a lot easier to fix in the base game than from ST+.
  • TrailerLoadFix has been removed, since the base game now allows to load unaligned full trailers.
  • Like 1
  • Thanks 5
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...