Jump to content
Oovee® Games

Recommended Posts

Fellow offroaders,

Arriving later than planned, v1.4.3 patch is now available on Steam.

We are working hard on the next major update which will primarily include multiplayer saves, which will initially be available under the public_beta branch.

Added / New

- Added "default" camera mode selector to options menu.

Improvements / Adjustments

- Changed orbital camera focus position.
- Truck mechanisms (crane, anchors, etc...) are now operated with keys 5 to 0 instead of Ctrl+1 to Ctrl+0.
- Pressing the trailer camera key ("2" by default) no longer does anything when there is no trailer.
- Mods altering DLC content now work when dropped in the Media folder.
- Orbital camera focus point moved toward the front of the truck.

Fixes

- Chernobyl DLC: Various map fixes.
- Chernobyl DLC: Missing files.
- Chernobyl DLC: 505 now spawns with a flatbed.
- Fixed engine braking wheels despite clutch being disengaged.
- Fixed ground disappearing at 8PM.
- Fixed random crash when main menu animation is at the end of its track.
- Fixed F1 minimap complaining about gui_radiation__d_a.dds even when ChernobylDLC is not installed.
- Fixed bugs in camera avoidance of obstacles.
- Fixed empty control list in control menu bug.
- Fixed gamepad control differences with v03.03.16.
- Fixed a radiation display bug on F1 map.
- Fixed spawn locator rings visible on F1 minimap even when these locators are disabled/invisible.
- Added DLC map names to main game localization so that players can see them on the MP lobby list.
- Fixed crane camera.
- Fixed a crash related to mod downloads.
- Fixed white screen when loading the "plains" map.
- Fixed a random crash related to lua.
- Orbital camera no longer allowed to clip into trailers.
  • Like 3
  • Thanks 1
Link to post
Share on other sites
6 hours ago, Zane (Oovee) said:

- Pressing the trailer camera key ("2" by default) no longer does anything when there is no trailer.

In MR this key switches to the other side of the truck when there's no trailer.  I only discovered this recently but it can be handy.  The bigger issue with trailers in ST, assuming this hasn't been fixed yet, is having to line them up perfectly with the truck to pack logs that are only on the trailer.

  • Like 1
Link to post
Share on other sites
12 hours ago, Zane (Oovee) said:

- Fixed engine braking wheels despite clutch being disengaged.

- Fixed ground disappearing at 8PM. 

- Fixed crane camera.

- Truck mechanisms (crane, anchors, etc...) are now operated with keys 5 to 0 instead of Ctrl+1 to Ctrl+0.

- Engine sound with clutch pressed is still not correct.  Engine should sound like it's in neutral.

- Ground is still disappearing in front of garage on Chernobyl proving ground, when tires slip on it on hard acceleration.

- Switching crane camera mode still affects truck camera mode, after you leave the crane operation.  In older versions the cameras were independent.

- '6' is a poor choice of a key for the crane grabber (requires 2 hands).  This should be possible to re-assign.  '4' was much better.

 

And Chernobyl's ground is still invisible in places.

CC8E44B388146C0119A929FAD38D01F6521322DF

Edited by Unster
Link to post
Share on other sites

That issue is a different issue from what was listed on the changelog.

Quote

- Fixed ground disappearing at 8PM.

With the listed issue; the ground would completely disappear from 8PM onward and we believe this has now been fixed.

--

Posting pictures of the misaligned ground collision isn't very helpful when we don't know where the location is. Show us on the map where this happens (and yes, some of them we have tried to fixed but have not been able to).

You're welcome

Link to post
Share on other sites

Yes, I know it's a different issue. The pictures are clearly not 8 pm (a bug I haven't experienced).

This problem is so widespread, it's going to take a lot of picture/map combination to illustrate, but if it will help, I will provide some.

There is tyre deformation, so they are touching ground, but it's not possible to see it, day or night.

If they can't be fixed, then so be it.

 

..

 

  • Like 2
Link to post
Share on other sites

Yeah, I just drove a little in the Chernobyl map from the starting location, I think it was west / northwest, just over the rail track, and the first dark dip in the mud I found had this issue.  It's impossible not to find if you play the map a little.

Link to post
Share on other sites

This map shows the road with the missing surface, shown in my pictures.

There is a new road system to the North of Chernobyl Dock, which has been drained and another system at the South of the map, which was a very large hole.

 

Time to go looksee..

20200310155133_1.jpg

Link to post
Share on other sites

Wow! What a pleasant surprise.

The 2 largest black holes on the whole map have now gone and been replaced by small mud rock strewn road systems.

So it can be done!

Afew deep water holes are included to catch out the unwary

 

..

 

20200310171826_1.jpg

20200310171955_1.jpg

20200310172050_1.jpg

Edited by Trackrod_ST
Link to post
Share on other sites
10 minutes ago, Trackrod_ST said:

The 2 largest black holes on the whole map have now gone and been replaced by small mud rock strewn road systems.

So it can be done!

So the map problems are being patched in the map one by one instead of being fixed at the source.  Not a good sign.

Link to post
Share on other sites

@Zane (Oovee)For what it's worth, here's the problem location corresponding to my screenshot above.  I'd also say the Geiger meter sound is obnoxiously loud while playing this map but that's the least of the problems.  The missing ground & ongoing stutter are much bigger gameplay killers for me.

Forgive us for being so critical lately, but we are losing confidence in this product that last year appeared so promising.  I still think 1.3.7 was the best version, even with the flawed mud traction that's been an issue since day 1.

 

66BE8744360115C8860F98E1F71043F7D7E4DED5

Link to post
Share on other sites

@Unster

Please don't include me in your "we". I'm very happy with this game and it's improving all the time.

I consider my input, not as critical, but feedback, which I believe is being acted on.

The worst areas of 'black hole' missing ground have been filled and I'm very pleased with it. Hopefully the remaining areas will be treated accordingly.

This map is the only real life area and I'm enjoying it. It is a great idea and beautifully made. I hope there will be more like it.

..

 

 

  • Like 3
Link to post
Share on other sites
1 hour ago, Zane (Oovee) said:

We are continually looking for why this is happening but nothing solid discovered yet 

What about to publish some beta version, open or closed for selected individuals of your choice, to just troubleshoot this issue?

Three major features (dynamic main menu background, advertising, 60fps unlock) has been added to 1.4.0 and after that the stuttering began, I think you could publish the 1.3.7 with each one of those features but one by one and we can report if the stutters is being introduced by that particular feature. If nothing comes out from this, we can start to make a combination of them and repeat the process.

It could be a nice and quick way to troubleshoot this issue and finally move forward to fix other essential things.

 

 

 

 

Edited by Zukakis
  • Like 3
Link to post
Share on other sites
6 hours ago, Trackrod_ST said:

Please don't include me in your "we". I'm very happy with this game and it's improving all the time.

OK.  I wasn't specifically including you, though you seemed to be complaining here too.  Namely I meant those of us voicing our frustration in the tire friction thread.  I wish the game was improving all the time, but that's simply not the case.  The new DLC's have brought a bunch of new issues, taking focus away from old issues, and the stuttering added with 1.4.0 made the game a lot less enjoyable.  You haven't noticed the difference?

Link to post
Share on other sites
2 hours ago, Zane (Oovee) said:

We are continually looking for why this is happening but nothing solid discovered yet 

I second what Zukakis said.  This has been the most frustrating part for me with this game.  The stutter was introduced sometime back in December and I was hoping it would be a quick fix as it shouldn't be that hard to find out what's causing it, since it's clearly one of the features added in 1.4.0.  3 months later, still no fix, not even a beta to test and help isolate the issue.

BTW, if you think it's just a few people here having this issue and it's low priority, have a look at these Steam threads.  Plenty of people outside this forum are seeing it.

https://steamcommunity.com/app/263280/discussions/0/2673381715700247700/

https://steamcommunity.com/app/263280/discussions/0/3987311729594057619/

Edited by Unster
  • Like 1
Link to post
Share on other sites

I think no one here wants to see the developments stops, that's why we are posting. Some 'direct', 'harsh', 'rough' comments have the same reason to be as other and lighter comments...give a feedback. Sometimes this feedback can be expressed as frustration because of all the issues that are worsening the experience, especially when some issue has been introduced during the development with new 'updates'. 

 

  • Like 1
Link to post
Share on other sites

Yup, we all care for the game, that's why we post here.  Some people may be more frustrated with the issues and more direct than others, but we all want the game to succeed, don't ever doubt that.

My personal philosophy is to be honest and to the point, rather than pretend everything is fine and saying great job all the time, as that only encourages failure.

Edited by Unster
  • Like 2
Link to post
Share on other sites

I created my own road surface for the road shown in my first set of screenies in this thread, but I've run out of MB space, (I can't see any way to manage the puny 25 mb limit).

Bummer!

I posted on Steam, where I have about 10000 screenshots.

..

 

Edited by Trackrod_ST
  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...