Jump to content
Oovee® Games

1.4.2 Stuttering and possible workaround


Recommended Posts

For those who are experiencing stuttering with builds 1.4.0+ I had huge improvements just changing a couple of settings. 

It would be nice if you guys can try it on your system and report here.

 

So, in Spintires settings:

Uncheck the 60FPS limit

 

In nVidia Control Panel, customize the setting for Spintires:

Max Frame Rate: 59 FPS (I have a 60Hz monitor and for some reason in many games I get smoother experience when setting it at 59 instead of 60)

Vertical Sync: On

Triple Buffering: On (Optional)

 

With these setting the game is much smoother than before, I would not call it "butter smooth" but it's definitely a lot better than before.

For those using AMD GPUs, there are similar drivers settings to play with and hopefully they help AMD users too.

EDIT: I am on a  Ryzen 5 3600, 16GB DDR4 2400, RTX 2060 6gb, Crucial SSD, 60Hz Monitor

Edited by Zukakis
Link to post
Share on other sites

Unfortunately I saw no improvement with these changes.

My favorite way of testing the stutter is to spawn a truck on the original Proving Ground, put a crane on, activate it, switch to roof cam, zoom out a little, and spin the crane around.  1.3.7. is so much smoother and it's still my favorite version.

Link to post
Share on other sites
3 hours ago, Unster said:

Unfortunately I saw no improvement with these changes.

My favorite way of testing the stutter is to spawn a truck on the original Proving Ground, put a crane on, activate it, switch to roof cam, zoom out a little, and spin the crane around.  1.3.7. is so much smoother and it's still my favorite version.

Sorry to know it didn't help. I'll try that sequence to see if I can trigger it.

EDIT: I tried your way, in my case it's not so smooth but I can't call it stutter, do you remember you wrote that you had stuttering in Chernobyl proving grounds after the mud section right after the beginning? I had it too, but now I have not it any more, I have it back if I revert the settings above. I really hope devs can fix it once for all. 1.3.7 was definitely smoother.

 

Edited by Zukakis
Link to post
Share on other sites

@Zukakis You could also try the crane spinning test in 1.3.7.  In my case the difference is huge.  The older version is butter-smooth, the new one has hiccups or stutter, call it what you will.

Yes I previously used the short test drive on Chernobyl proving ground, but that's a little less clear, though I can still tell the difference.  I tried that with your settings as well.

Link to post
Share on other sites

Well, even if it's better now I can't say that it's as smooth as the 1.3.7 

Without these settings I don't need to make test to see the stuttering, just start a game and after few meters it begins and it's not pleasing to play the game like this. With these settings I can better enjoy the latest build too.

I am for reverting the game to the locked fps version in future builds, if Oovee can't reproduce and fix the issue. I don't think ST is the kind of game that needs to have unlocked fps, not at this price (stuttering for some players) at least. 

Edited by Zukakis
  • Like 1
Link to post
Share on other sites

Yeah I didn't hear anyone say how great the fps unlock was.  I've only heard complaints about it.  Of course the stutter could be caused by something else, but looking at the changelist I consider it the prime suspect.

Link to post
Share on other sites
  • 1 month later...

@ZukakisThis is interesting.  I've been able to restore 1.3.7-like smoothness by setting my max frame rate to 60 in the NVIDIA control panel, which matches my monitor refresh rate.  It does look like the fps unlock in 1.4.0 was what broke the smoothness, and the option in the game's menu to enable the fps cap doesn't work.  The key is to do it through the NVIDIA control panel (or if you have an AMD card then whatever panel AMD has).  I have all my other ST settings in the control panel set to global.

Link to post
Share on other sites
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...