Jump to content
Oovee® Games

Archived

This topic is now archived and is closed to further replies.

Sandmansa

Need help with log loads

Recommended Posts

Ever since the latest update, I am unable to figure out how to load logs onto other trailers or logging carts.

 

Use to be able to define other trailer loads in the classes/models folder with say a log_medium_b.xml for example. But this no longer works.

 

Can anyone help me figure out what got changed?

Share this post


Link to post
Share on other sites

It's the weekend in most parts of the world. I'd wait a little longer.

Share this post


Link to post
Share on other sites

Ever since the latest update, I am unable to figure out how to load logs onto other trailers or logging carts.

 

Use to be able to define other trailer loads in the classes/models folder with say a log_medium_b.xml for example. But this no longer works.

 

Can anyone help me figure out what got changed?

 

I didn't see anything about any changes to the methods or coding for log loads in the update notes. Did this one slip through the net?

Share this post


Link to post
Share on other sites

I don't know how, but when they added the maz2 log load option, something got changed. You can only have 1 of each log load option. Short, medium or long. So for example, you have a modded truck that can carry the medium logs in more then 1 configuration, (say the default log cart with trailer and a addon maz2 sized log cart) the game will only use the default option. Now, if you were to delete the default loadlogsmedium line from the trucks xml file, the addon cart option will allow you to load up, but not the default option.

 

Also, mods that have a rocks load option won't work anymore either.

 

I don't know if this is a new bug or if this was intended. But I'm suspecting bug.

Share this post


Link to post
Share on other sites

 changed classes/models folder 

 

 

<ModelBrand Dynamic="true"  into <ModelBrand DynamicModel="true"

 

<GameData LoadAddon...  into <GameData LoadAddons...

 

 

 

 

 

Share this post


Link to post
Share on other sites

My issue in all maps is when I get to Lumber, the load menu only shows "Kirpich, Load Huge Rocks and Load Rocks".

 

I've had a search through the forum but can't find a solution to this - or do I need to do the above editing in my classes/models folder? In one map, the only lumber yard has no actual logs in it....hmmm (very confused...)

 

Hope you can help.

Share this post


Link to post
Share on other sites

My issue in all maps is when I get to Lumber, the load menu only shows "Kirpich, Load Huge Rocks and Load Rocks".

 

I've had a search through the forum but can't find a solution to this - or do I need to do the above editing in my classes/models folder? In one map, the only lumber yard has no actual logs in it....hmmm (very confused...)

 

Hope you can help.

Sounds like you aren't talking about modding logs, right?

If so: You have a mod installed that replaces logs with stones. You need to delete this mod from your media folder.

Share this post


Link to post
Share on other sites

Sounds like you aren't talking about modding logs, right?

If so: You have a mod installed that replaces logs with stones. You need to delete this mod from your media folder.

 

You must walk amongst the gods Marijn. I did indeed add a mod for rocks. I didn't realise what it's outcome would be. I shall now find and remove it.

 

Many many thanks for your helpful reply.

Share this post


Link to post
Share on other sites

My problem now is the lumber loading drop down menu doesn't have anything on it after deleting my rock mod files.

 

Do you think I should uninstall my legacy ST and reinstall again?

Share this post


Link to post
Share on other sites

My problem now is the lumber loading drop down menu doesn't have anything on it after deleting my rock mod files.

 

Do you think I should uninstall my legacy ST and reinstall again?

I think best is to uninstall all mods (delete everything from your media folder except the videos folder), then go into %appdata%/Spintires and delete the TexturesCache folder and the MeshCache.mhc and ShaderCache.shc file. Then verify the app integrity in steam (google this or look around the forums if you don't know how). Now you should start ST and be able to see it again.

Share this post


Link to post
Share on other sites

Hmm, I'm now having problems with my lumber menu - no logs showing..... and that's on all my maps,

 

 

http://cloud-4.steamusercontent.com/ugc/710780552644504107/3F2B38DCFAF490ACD88A0B6613A6359C6DA1E76E/

 

Hope this image works - please be patient.

 

BTW, if the image works (and I'm pulling my hair out here), what is the strange shape that looks like a camera silhouette under the truck?

 

 

post-107683-0-63647600-1427239047_thumb.jpg

Share this post


Link to post
Share on other sites

Your game still definately is modded. The camera is for hood/roof cam, which'll be put at the (0,0,0) coordinate if it's location is not defined (cam was only introduced in the latest update, not all mods are fitted with this).

 

Again I suggest you to get rid of everything (explained post above) and try again.

Share this post


Link to post
Share on other sites

im gonna ask this here instead of starting a new topic.  i noticed using Brutes F350 and Kraz 6316 when hauling logs that when i drop the load or fall over that no logs are actually dropped and the entire load just disappears.   is there a way to make it so that if i drop my load, i can load the dropped logs back into the cart like the stock trucks?

Share this post


Link to post
Share on other sites

Your game still definately is modded. The camera is for hood/roof cam, which'll be put at the (0,0,0) coordinate if it's location is not defined (cam was only introduced in the latest update, not all mods are fitted with this).

 

Again I suggest you to get rid of everything (explained post above) and try again.

 

Aha....... it worked. Thank you very much for your help - much appreciated.

Share this post


Link to post
Share on other sites

im gonna ask this here instead of starting a new topic.  i noticed using Brutes F350 and Kraz 6316 when hauling logs that when i drop the load or fall over that no logs are actually dropped and the entire load just disappears.   is there a way to make it so that if i drop my load, i can load the dropped logs back into the cart like the stock trucks?

 

I would be interested in knowing the answer to this myself.

Share this post


Link to post
Share on other sites

Short answer: Yes.

 

Long answer: You will have to wait until I have put the kids to bed.

 

Cool.  I've been trying to learn this on my own but with no success.

Share this post


Link to post
Share on other sites

In classes/models there are the three files that relate to the loadable logs, log_medium_a.xml, log_short_a.xml and log_long_a.xml

 

In log_medium_a.xml there is a line:

<GameData LoadAddons="load_logs_medium,load_logs_medium2">

Which allows the medium logs to be used for the log cart/cart with crane + med log trailer as well as for the E-7310's log cart. To add your own you just add in your log load:

<GameData LoadAddons="load_logs_medium,load_logs_medium2,load_logs_pressureline">

You'll probably need to also have something like this set up in the addon xml in classes/trucks:

<GameData>
	<InstallSocket Type="Maz2Utility" />
	<LoadArea
		Type="MediumLogs"
		Min="(-5.806; 1.816; -1.65)"
		Max="(-4.360; 2.65; 1.65)"
	/>
	<LoadArea
		Type="MediumLogs"
		Min="(-2.059; 1.816; -1.65)"
		Max="(-0.374; 2.65; 1.65)"
	/>
</GameData>

Share this post


Link to post
Share on other sites

Okay, that much I know.  But now, I need to get a little more technical.  Let's use this for example.  I have an addon log cart that's similar to the maz2 log cart, where it can carry the medium log load in the cart without a trailer.  But this cart is not as wide as the maz2 cart so it has to use the regular medium log load in order to fit it, but without the ragdoll effect that would normally allow it to flex with a small trailer.  How would you make this work so you can reload the logs or load manually?

Share this post


Link to post
Share on other sites

I would basically do what I have done above.

 

Copy classes/trucks/load_logs_medium.xml and rename it load_logs_medium3.xml. In that file change this:

<Constraint
	Type="Ragdoll"
	PlaneAxis="(0; 0; 1.0)"
	TwistAxis="(1.0; 0; 0)"
	TwistMin="-180"
	TwistMax="180"
/>

To this:

<Constraint
	Type="Fixed"
/>

And save it. This will remove the 'ragdoll' effect from the log load.

 

Then in classes/models/log_medium_a.xml change this:

<GameData LoadAddons="load_logs_medium,load_logs_medium2">

To this:

<GameData LoadAddons="load_logs_medium,load_logs_medium2,load_logs_medium3">

And then just make sure the loading zones on the addon are positioned appropriately. The centres should be ~4m apart :) You'll also want to ensure that the RequiredAddon is set appropriately (in the classes/trucks/load_logs_medium3.xml) in this case something like:

<RequiredAddon Type="medium_log_cart" />

or whatever the addon in question is called :)

Share this post


Link to post
Share on other sites

i tried what you suggested PL and it didnt help.  Removing the ragdoll actually made the f350 act as one long truck when loaded up with logs.    it still doesnt drop logs when i drop the load.   with the stocks trucks it will drop 2 or 3 logs so i can re load the with the crane and thats what i want with brutes f350 and brutes kraz 6316. 

Share this post


Link to post
Share on other sites

Yes, because that's because my last post was a reply to Sandmansa's question. All you should need to do is this part:

 

In classes/models/log_medium_a.xml change this:

<GameData LoadAddons="load_logs_medium,load_logs_medium2">

To this:

 

<GameData LoadAddons="load_logs_medium,load_logs_medium2,load_logs_brutef350">

 

Obviously you will need to change load_logs_brutef350 to whatever is appropriate for the F350.

Share this post


Link to post
Share on other sites

×
×
  • Create New...